The performance issues affecting analytics pages in the Skilljar admin dashboard have been fully resolved. Page load times are back to normal and the platform is operating as expected.
We appreciate your patience while our team worked through this issue.
Posted Apr 03, 2026 - 16:00 PDT
Monitoring
A fix has been deployed to address the degraded performance affecting analytics pages in the Skilljar admin dashboard. Page load times should now be improving.
Our engineering team is actively monitoring to confirm the fix is holding and performance has fully stabilized. If you continue to experience any issues, please reach out to our support team.
Posted Apr 03, 2026 - 15:33 PDT
Identified
Our engineering team has identified the root cause of the degraded performance affecting analytics pages in the Skilljar admin dashboard. A fix has been developed and is being deployed now.
Users may continue to experience slower than expected load times on analytics views while the fix rolls out. All other platform functionality remains unaffected.
We will provide another update once the fix is in place and we have confirmed performance has stabilized. Thank you for your patience.
Posted Apr 03, 2026 - 15:12 PDT
Update
Our engineering team continues to investigate the degraded performance affecting analytics pages in the Skilljar admin dashboard. We have identified several areas of interest and are actively working to isolate the root cause.
Users may still experience slower than expected load times when accessing reporting and analytics views. All other platform functionality remains unaffected.
We will continue to provide updates as our investigation progresses. Thank you for your continued patience.
Posted Apr 03, 2026 - 08:48 PDT
Investigating
We are currently investigating reports of degraded performance on analytics pages within the Skilljar admin dashboard. Some users may experience slower than expected load times or timeouts when accessing reporting and analytics views.
Our engineering team is actively looking into the root cause. Core platform functionality, including course delivery, learner access, and content management, remains unaffected.